How to Cleanup Incorrectly Configured Docker Storage
Problem
Docker cannot start up on the nodes due to incorrectly configured Storage. The following error is observed in docker logs journalctl -u docker
S-NOR-KUB02 dockerd[14104]: failed to start daemon: error initializing graphdriver: devmapper: Unable to take ownership of thin-pool (docker--vg-thinpool) that already has used data blocksIf storage for docker was manually configured without the required parameters the Platform9 implementation will not be able to utilize it.
Environment
Platform9 Managed Kubernetes - All Versions
Docker
LVM
Procedure
Warning
This will delete all the data currently present in the Volume Group. If you wish to retain this data please take backup before this process.
1 - Make sure you have unmounted all the PV which are a part of this Volume Group. Once that is done you can remove the Logical volumes associated with them.
$ sudo lvremove -f <__vg_name__>/<__lv_name__>2 - To remove the Volume Group we have deactivate it first.
$ vgchange -an <__vg_name__>3 - Remove the VG
4 - Once the Volume Group is deleted, follow the steps given in this article to setup Docker Storage for your Platform9 Managed Node
Last updated
