ETCD Backup Job Warnings Seen In Kubelet Logs
Problem
The Kubelet logs showing error messages with etcd backup batch job object has been modified as shown below:
E0116 02:00:00.307226 1 job_controller.go:533] syncing job: Operation cannot be fulfilled on jobs.batch "etcd-backup-with-timestamp-27897240": the object has been modified; please apply your changes to the latest version and try again1 cronjob_controllerv2.go:193] "error cleaning up jobs" cronjob="default/sa-history-scheduler" resourceVersion="7543670" err="Operation cannot be fulfilled on cronjobs.batch \"sa-history-scheduler\": the object has been modified; please apply your changes to the latest version and try again"
error cleaning up jobs" cronjob="kube-system/etcd-backup" resourceVersion="7512521" err="Operation cannot be fulfilled on cronjobs.batch \"etcd-backup\": the object has been modified; please apply your changes to the latest version and try again"
reconciling cronjob" cronjob="kube-system/etcd-backup" err="resource name may not be empty"Environment
Platform9 Managed Kubernetes - v5.5.0 and Higher.
Answer
It is confirmed that the warnings seen are harmless. This issue is resolved in the latest PMK releases.
Additional Information
PreviousNot Able To Add New Nodes to PMK Cluster
NextHow To Use Custom PVC For Prometheus Monitoring Addon From The Management Plane UI?
Last updated
