DU VM is not Starting up due to Memory Exhaustion Over DU Host
Problem
The DU VM is in shutoff state in the virsh list output.
Libvirtd is complaining
The workload cluster is running as expected.
Environment
Platform9 Edge Cloud
Cause
Due to not having enough free memory over the DU Host; the DU VM does not get provisioned. Libvirtd throws the below error in relevance to the memory scarcity.
Jul 12 08:58:12 example.com libvirtd: 2024-07-08 04:03:24.312+0000: 1895: error : qemuMonitorOpenUnix:379 : failed to connect to monitor socket: No such process
Jul 12 08:59:22 example.com libvirtd: 2024-07-12 15:59:22.303+0000: 2206: error : virFork:332 : cannot fork child process: Cannot allocate memoryResolution
As per the default value for
vmMemoryMb, DU VM requires minimum 8192Mi of memory (~8 GB) to be provisioned and run over DU Host. The value vmMemoryMb can be fetched from airctl-config.yaml file in DU Host
PreviousThe Grafana Link For Clusters is Not Working, Lands Back on the UI's Manager page
NextNodelet Failing at Configure Container Runtime Phase due to Unexpected Disk Mounts
Last updated
