CertManager Installed as Part of Luigi Installation Impacting Custom CertManager
Problem
After enabling the Luigi addon, the custom cert-manager deployed fails.
The
cert-manager-cainjectorpod goes in CrashLoopBackOff state.cert-manager-cainjectorpod logs the below errors:
E0423 14:18:27.390834 1 reflector.go:158] "Unhandled Error" err="k8s.io/client-go@v0.31.1/tools/cache/reflector.go:243: Failed to watch *v1.Order: failed to list *v1.Order: orders.acme.cert-manager.io is forbidden: User \"system:serviceaccount:cert-manager:cert-manager\" cannot list resource \"orders\" in API group \"acme.cert-manager.io\" at the cluster scope" logger="UnhandledError"Environment
Platform9 Managed Kubernetes v5.9.4 and Higher.
Kubernetes Version: 1.25 and Higher.
Resolution
This is a known issue and is already internally reported internally with: PMK-6659
Workaround
Additional Information
Reach out to Platform9 Support Team for more details on the bug/workaround.
PreviousGrafana Link in the UI is Redirecting to Management Plane Home Page
NextThe Grafana Link For Clusters is Not Working, Lands Back on the UI's Manager page
Last updated
