# Hypervisor is Reporting Offline to The Management Plane

## Problem

Hypervisor is reporting as offline to the Management Plane

## Environment

* Platform9 Managed OpenStack - All Versions
* Platform9 Managed Kubernetes - All Versions.

## Cause

The disk space on the **/var** mount point on which the logs and Virtual Machine details are stored do not have any free space left. Below errors are observed in the */var/log/pf9/hostagent-daemon.log*

{% tabs %}
{% tab title="logs" %}

```none
--- Logging error ---
Traceback (most recent call last):
  File "/opt/pf9/python/lib/python3.6/logging/__init__.py", line 998, in emit
    self.flush()
  File "/opt/pf9/python/lib/python3.6/logging/__init__.py", line 978, in flush
    self.stream.flush()
OSError: [Errno 28] No space left on device

Call stack:
  File "/opt/pf9/hostagent/bin/pf9-hostd", line 18, in <module>
    import bbslave.main
```

{% endtab %}
{% endtabs %}

## Resolution

1. Make sure the mount point on which the Virtual Machine disks and logs have free disk space available.
2. Once we have enough free disk space restart the ***pf9-hostagent*** service. The ***pf9-hostagent***&#x73;ervice will restart other Platform9 services running on the system.

{% tabs %}
{% tab title="command" %}

```none
# sudo sysmtectl restart pf9-hostagent
```

{% endtab %}
{% endtabs %}
