Hostagent Logs Shows "Cert Update Thread Is Waiting With Timeout of 24 Hours"

Problem

Node doesn't converge to the Platform9 Management Plane. Hostagent logs show entries like below every 24 hours. However, nodes remain in a disconnected state on the PMK GUI.

2023-05-26 09:53:33,101 - cert_update_thread.py INFO - CA list returned by vouch is subset of CAs on host. No CA update needed.
2023-05-26 09:53:33,103 - cert_update_thread.py INFO - Cert Update thread is now waiting on an event with timeout of 24 hours
2023-05-27 09:53:37,102 - cert_update_thread.py INFO - CA list returned by vouch is subset of CAs on host. No CA update needed.
2023-05-27 09:53:37,105 - cert_update_thread.py INFO - Cert Update thread is now waiting on an event with timeout of 24 hours

Environment

  • Platform9 Managed Kubernetes - v5.6.4 and Higher.

Cause

  • The issue happens due to the node clock is not in sync.

$ timedatectl
      Local time: Wed 2023-06-07 10:02:28 UTC
  Universal time: Wed 2023-06-07 10:02:28 UTC
        RTC time: Wed 2023-06-07 09:59:17
       Time zone: UTC (UTC, +0000)
     NTP enabled: yes
NTP synchronized: no
 RTC in local TZ: no
      DST active: n/a

Resolution

  • Sync the node clock using timedatectl and hwclock command followed by pf9-hostagent service restart.

  • Verify if clock is synced.

  • Restart the pf9-hostagent service.

  • Verify if the service is running and the node started converging to the management plane. GUI should show the node as connected.

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