# ARS Login Failed: pf9 Account or Password is Expired

## Problem

* Unable to get SSH access though ARS is enabled for the hosts.
* SSH access asks for a password for the pf9 user.
* Error shows below messages while trying to access.

{% tabs %}
{% tab title="SSH to Hosts: Error messages" %}

```javascript
Your account has expired; please contact your system administrator

OR

WARNING: Your password has expired.
You must change your password now and login again!
```

{% endtab %}
{% endtabs %}

## Environment

* Platform9 - All Managed Offering Products

## Cause

Either password or account is expired for pf9 user, as user account and password expiration limit is set and expired already.

## Resolution

* Check the expiration date set for pf9 user using chage command shown below:

{% tabs %}
{% tab title="Chage to check expiration" %}

```javascript
# chage -l pf9
Last password change : Mar 13, 2022
Password expires : Jun 13, 2022
Password inactive : Jun 13, 2022
Account expires : Jun 13, 2022
Minimum number of days between password change : 0
Maximum number of days between password change : 99999
Number of days of warning before password expires : 7
```

{% endtab %}
{% endtabs %}

* Change password using chage

{% tabs %}
{% tab title="Chage command" %}

```javascript
# chage -m 0 -M 99999 -E -1 pf9    //for account to never expire

OR
# chage --help    //explore chage flags
```

{% endtab %}
{% endtabs %}

* Verify the change

{% tabs %}
{% tab title="After limit updation" %}

```javascript
# chage -l pf9
Last password change : Mar 13, 2022
Password expires : never
Password inactive : never
Account expires : never
Minimum number of days between password change : 0
Maximum number of days between password change : 99999
Number of days of warning before password expires : 7
```

{% endtab %}
{% endtabs %}
