# Instance Fails to Live-Migrate: "No valid host was found

## Problem

* An instance is failing to live-migrate with "No valid host was found".
* The instance is associated with an Availability Zone.
* The live-migration is shown to be in error as per **`nova server-migration-show`**.
* In */var/log/nova/nova-scheduler.log* on the Management Plane, the following is observed.

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```none
INFO nova.filters [...] Filtering removed all hosts for the request with instance ID '[INSTANCE_UUID]'. Filter results: ['RetryFilter: (start: 1, end: 1)', 'AggregateMultiTenancyIsolation: (start: 1, end: 1)', 'AvailabilityZoneFilter: (start: 1, end: 0)']
```

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## Environment

* Platform9 Managed OpenStack - v3.11 and Lower
* Nova

## Cause

The instance is being attempted to be live-migrated across Availability Zones, which is not allowed.

## Resolution

### Adding Additional Hosts

1. In Clarity UI, navigate to "Infrastructure" → "Host Aggregates".
2. Select the radio button next to the name of the host aggregate associated with the AZ for which the instance is provisioned under.
3. Click "Edit Host Aggregate".
4. Select the checkbox next to each additional host to be added to the aggregate.
5. Click "Save".
6. The host should now show for the AZ under the Availability Zones tab.
7. Retry the live-migration.

## Additional Information

* [Platform9 Docs - Host Aggregates](https://docs.platform9.com/openstack/infrastructure/host-aggregates/)
